Player V3 - Comparison Between HTML5 and Flash Players (Deprecated)

Helps you decide which Player V3 to implement: the HTML5 Player or Flash Player.

Note: Ooyala Player V3 has been deprecated and is scheduled to be disabled. For details and alternatives, see the OVP Release Notes.
Player V3 provides the ability to let the player automatically switch between HTML5 and Flash to optimize itself to its environment.
  • You can embed a player on your web page that supports Flash with a fallback to HTML5 for devices that do not support Flash.
  • You can also set HTML5 as the default player with Flash as a fallback for cases where HTML5 is not supported.
  • If you want to provide a completely consistent, though possibly less powerful playback experience, you can set HTML5 as your default player.
When deciding how best to approach using the player, consider the following examples.
If ... then consider using
Your viewers are all restricted to HTML5-only devices (for example, iOS devices do not support Flash) HTML5 exclusively.
Your viewers want HTML5 for an optimal desktop experience HTML5 with Flash fallback.
You want the ability to customize the player, take advantage of the quick load times of HTML5, or use some of the other HTML5 features not readily available in Flash HTML5 only across all devices, with the understanding that your content will not work on Flash-only devices (e.g. a desktop with IE6 browser).
You want greater device coverage but also want to make your content available for devices that support Flash HTML5 with Flash fallback.
You have viewers who want the features available in Flash or Flash is optimal for a large segment of your audience Flash with HTML5 fallback.
Your users are all restricted to Flash supported devices and want the features available in Flash Flash exclusively.
You want to use ActionScript to control the player Use Player (V2) for Flash (see V2 Player APIs (Player V2 Deprecated))

For more information about the devices and players we support, see Player V3 System Requirements and Compatibility (Deprecated)

해당 내용이 도움 되었습니까?