2016-12-01 Release

New Forecast REST API endpoint, macros related to mobile app parameters for RTB, volume related events on HTML5 ad player, next version of contrib-ads (4.x) supported in VideoJS plugin.

Forecast REST API Endpoint to Get the Projected Delivery of All Active Goals

Note: This endpoint does not enable you to get the projected delivery of a campaign.

A new Forecast REST API endpoint is available to interact with Ooyala Pulse. This endpoint enables you to get the projected delivery of all active goals, meaning their end date falls within the next 100 days. This was previously possible only by hovering over individual goal progress bars in the Pulse user interface.

You get the projected delivery for these goals whether or not the campaign has been turned on. You do not get the projected delivery for:
  • goals with an end date more than a 100 days into the future
  • goals without an end date
  • goals without ads
  • goals with ads that have never been turned on

The projected delivery of a goal is embedded in the goal progress bar and represents the total number of impressions projected to be delivered over the projection period (usually 100 days), including the already delivered impressions. The projected delivery is continuously refreshed through a background simulation on the whole account, forecasting up to 100 days into the future.

Macros Related to Mobile App Parameters for Real-Time Bidding

Information passed in from mobile application should be passed on to DSPs in case of real-time bids, so they can do better matching of bids and provide more tracking information to the advertisers. These macros are described in Appendix D - Pulse Macros.

Volume Related Events on HTML5 Ad Player

From version 2.1.16.22.0, the HTML5 ad player enables access to the following volume related settings on the ad player:
  • mute the ad player,
  • unmute the ad player, and
  • get the volume from the ad player.

Next Version of contrib-ads (4.x) Supported in VideoJS Plugin

From version 2.x, the VideoJS Plugin is compatible with version 4.x and higher of contrib-ads, necessary to serve ads in your VideoJS integration with Pulse. A new main version of the VideoJS Plugin was necessary to enable you to upgrade your contrib-ads version, because breaking changes were introduced in version 4.x of contrib-ads.

Note: When upgrading your integration, no other alterations need to be made. You only need to pay attention to use compatible versions of the plugin and contrib-ads. A compatibility matrix is available on the GitHub repository for the VideoJS Plugin.

Documentation Releases

This release includes the following documentation updates:

Subscribe to Ooyala Release Notes

See Subscribe to Ooyala Release Notes for instructions on how to subscribe for automated notifications of Ooyala release notes.

해당 내용이 도움 되었습니까?